WordPress由Win空间转到Linux空间出现错误

偶看博客原来使用的是Windows虚拟空间,转到Linux空间后马上就遇到了问题,访问首页出现如下提示:

Warning: Cannot modify header information – headers already sent by (output started at /data/home/oukan.net/htdocs/wp-config.php:1) in /data/home/oukan.net/htdocs/wp-includes/pluggable.php on line 866

打开 pluggable.php 没有发现有什么不同,原来是wp-config.php的UTF编码问题,需要去BOM

使用的Notepad++可以快速解决这个问题,本机只有英文版,修改这个我们需要用到的功能不多,不会妨碍使用。

notepad修改utf8-without-bom

先打开wp-config.php文件,然后点击Encoding–Encode in UTF-8 without BOM,再将文件保存,上传到服务器即可。

中文版显示界面

notepad-cn

问题马上就解决了。

Notepad++下载地址:http://dl.pconline.com.cn/html_2/1/117/id=10699&pn=0.html

《WordPress由Win空间转到Linux空间出现错误》有5个想法

发表评论